Linear Collider Forum



Home » Simulation » Mokka » problems with mokka in v01-04
problems with mokka in v01-04 [message #1653] Wed, 03 December 2008 07:53 Go to next message
iglesias
Messages: 18
Registered: November 2008
Location: Universidad de Santiago (...

Hello:
I have installed the release v01-04 sucessfully except the mokka package. When I run the script installation I obtain the next error message:
****************************** Installing software ******************************

############################################################ ####################
##### Compiling Mokka version mokka-06-06-p03...
############################################################ ####################

----- adding additional commands to build_env.sh :


----- adding additional command to build_env.sh . ${G4ENV_INIT}

In your environment you have the G4WORKDIR=/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my _v01-04/Mokka/mokka-06-06-p03
make[1]: Entering directory `/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/M okka/mokka-06-06-p03/source/Geometry/Calice'
make[1]: Nothing to be done for `all'.
Using granular libraries ...
Linking Mokka ...

/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/Mo kka/mokka-06-06-p03/tmp/Linux-g++/Mokka/exe/Mokka.o: In function `G4VisExecutive::RegisterGraphicsSystems()':
Mokka.cc:(.text+0x395): undefined reference to `G4RayTracerX::G4RayTracerX()'
collect2: ld returned 1 exit status
make[1]: *** [/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/M okka/mokka-06-06-p03/bin/Linux-g++/Mokka] Error 1
make[1]: Leaving directory `/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/M okka/mokka-06-06-p03/source/Kernel'
make: *** [all] Error 2
*** ERROR in module [ Mokka ]: Required file not found: ['/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/ Mokka/mokka-06-06-p03/bin/Linux-g++/Mokka']

And If I see in the /ilcinstall/my_v01-04/Mokka/mokka-06-06-p03/ directory it seems thar all the files have been installed except the Mokka file in the /bin/Linux-g++/ directory.

What is happening?


Regards

Carmen
P.D: In my script I put:
ilcsoft.install( Mokka( ilcPath + "v01-04/Mokka/mokka-06-06-p03" ))
and I have also tested with another options, (but I obtain the same error message)
ilcsoft.install( Mokka( "mokka-06-06-p03" ))
Re: problems with mokka in v01-04 [message #1676 is a reply to message #1653] Wed, 07 January 2009 01:36 Go to previous messageGo to next message
engels
Messages: 106
Registered: August 2006
Hi Carmen,

the problem seems to be some incompatibility between the Mokka and the Geant4 versions.. What Geant4 version are you using?

Are you using the desy afs installation @ /afs/desy.de/group/it/ilcsoft/v01-04 ?

Cheers,
Jan
Re: problems with mokka in v01-04 [message #1679 is a reply to message #1676] Thu, 08 January 2009 01:52 Go to previous messageGo to next message
iglesias
Messages: 18
Registered: November 2008
Location: Universidad de Santiago (...

Hello:
This is that i have put in my installation script about Geant4:

# Geant 4
ilcsoft.link( Geant4 ( ilcPath + "geant4/9.1" ))
ilcsoft.module("Geant4").env["G4ENV_INIT"] = ilcPath + "geant4/env_9.1.sh"


Is that correct?

Carmen

Re: problems with mokka in v01-04 [message #1680 is a reply to message #1679] Thu, 08 January 2009 06:56 Go to previous messageGo to next message
engels
Messages: 106
Registered: August 2006
Hi Carmen,

yes, that should be correct if you are using sl3 or sl4 machine..

could you try erasing your Mokka directory (/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/M okka/) and rerun ilcsoft-install with the same configuration file to check if the error still persists?

Cheers,
Jan

Re: problems with mokka in v01-04 [message #1683 is a reply to message #1680] Mon, 12 January 2009 05:03 Go to previous messageGo to next message
iglesias
Messages: 18
Registered: November 2008
Location: Universidad de Santiago (...

Hello:
If I erase the mokka directory and rerun ilcsoft-install I obtain at the end, the next error message:

[iglesias@fpmac116 ilcinstall]$ ./ilcsoft-install -i my_install_v01-04.cfg

****************************** Starting installation ******************************

+ Read configuration file [ my_install_v01-04.cfg ]

+ Initialize modules...

+ Check for previous installations...

+ [/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/l cio/v01-10-01] installation status: OK - set to use mode
+ [/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/M arlin/v00-10-03] installation status: OK - set to use mode
+ [/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/C EDViewer/v00-06] installation status: OK - set to use mode
+ [/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/L CFIVertex/v00-02-07-dev] installation status: OK - set to use mode
+ [/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/S iliconDigi/v00-04-01] installation status: OK - set to use mode
+ [/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/O verlay/v00-02] installation status: OK - set to use mode
+ [/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/E utelescope/v00-00-06] installation status: OK - set to use mode
+ [/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/M arlinTPC/v00-02-06] installation status: OK - set to use mode
+ [/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/S tandardConfig/v00-06-00] installation status: OK - set to use mode
+ [/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/M arlinReco/v00-10-04] installation status: OK - set to use mode
+ [/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/P andoraPFA/v02-03-00] installation status: OK - set to use mode
+ [/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/M arlinUtil/v00-11] installation status: OK - set to use mode
+ [/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/L CFI_SGVbasedNets/v00-01] installation status: OK - set to use mode
+ [/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/C ED/v00-05] installation status: OK - set to use mode
+ [/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/l ccd/v00-03-06] installation status: OK - set to use mode
+ [/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/R AIDA/v01-04-02] installation status: OK - set to use mode
+ [/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/C Make/2.4.6] installation status: OK - set to use mode
+ [/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/C ondDBMySQL/CondDBMySQL_ILC-0-5-10] installation status: OK - set to use mode
+ [/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/C MakeModules/v01-07] installation status: OK - set to use mode
+ [/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/g ear/v00-09] installation status: OK - set to use mode

+ Dependencies Pre-Check...

+ Dependencies Check...

+ Dependencies Post-Check...


****************************** Starting ILC Software installation process ******************************


****************************** Creating symlinks ******************************

+ Linking /mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/ro ot/5.16.00 -> /afs/desy.de/group/it/ilcsoft/root/5.16.00
+ Linking /mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/ge ant4/9.1 -> /afs/desy.de/group/it/ilcsoft/geant4/9.1
+ Linking /mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/ce rnlib/2006 -> /afs/desy.de/group/it/ilcsoft/cernlib/2006
+ Linking /mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/ja va/1.6.0 -> /afs/desy.de/group/it/ilcsoft/java/1.6.0

****************************** Checking for rebuilds ******************************


****************************** Downloading sources ******************************

************************************************************ ********************
*** Downloading sources for Mokka version mokka-06-06-p03...
************************************************************ ********************
--13:58:32-- http://polywww.in2p3.fr/activites/physique/geant4/tesla/www/ mokka/software/mokka_tags/Mokka-mokka-06-06-p03.tgz
Resolving polywww.in2p3.fr... 134.158.128.2
Connecting to polywww.in2p3.fr|134.158.128.2|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
13:58:32 ERROR 404: Not Found.

*** ERROR in module [ Mokka ]: Problems ocurred downloading sources!!

What does it mean?
What can I do?

Thanks.

Carmen
Re: problems with mokka in v01-04 [message #1687 is a reply to message #1683] Tue, 20 January 2009 00:52 Go to previous messageGo to next message
engels
Messages: 106
Registered: August 2006
Hi Carmen,

sorry for the late reply.

it seems that your configuration file is set to download the mokka 06-06-p03 tarball, which does not exist. you need to download this version of mokka with cvs by placing following line in your configuration file:
ilcsoft.module( "Mokka").download.type="cvs"


Cheers,
Jan
Re: problems with mokka in v01-04 [message #1768 is a reply to message #1653] Mon, 22 June 2009 04:24 Go to previous messageGo to next message
engels
Messages: 106
Registered: August 2006
Hi Carmen,

sorry if this post got somehow fallen into oblivion.

The problem you've reported on your first message (quoted below) happens because you have the environment variable G4VIS_USE_RAYTRACERX set on your system (maybe from a previous geant4 installation)

To fix the problem you should just need to unset it and recompile Mokka.

Cheers,
Jan

Quote:


/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04/Mo kka/mokka-06-06-p03/tmp/Linux-g++/Mokka/exe/Mokka.o: In function `G4VisExecutive::RegisterGraphicsSystems()':
Mokka.cc:(.text+0x395): undefined reference to `G4RayTracerX::G4RayTracerX()'
collect2: ld returned 1 exit status

Re: problems with mokka in v01-04 and also v01-06 [message #1859 is a reply to message #1687] Thu, 24 September 2009 03:56 Go to previous messageGo to next message
iglesias
Messages: 18
Registered: November 2008
Location: Universidad de Santiago (...

Hello:
Now, I try to install the new version v01-06, and at finish of the installation I obtain the same error message with respecto to Mokka (the rest of the packages have been installed OK)

make[1]: Leaving directory `/mnt/data2/ilcsoft/v01-06/Mokka/mokka-06-07-patch01/source/ Kernel'
make[1]: Entering directory `/mnt/data2/ilcsoft/v01-06/Mokka/mokka-06-07-patch01/source/ Kernel'
Compiling Control.cc ...
Compiling ControlMessenger.cc ...
Compiling DummyPhysicsList.cc ...
Compiling EventAction.cc ...
Compiling GeneralPhysics.cc ...
Compiling GPSGenerator.cc ...
Compiling GuineaPigInterface.cc ...
Compiling HepLCIOInterface.cc ...
src/HepLCIOInterface.cc: In member function ‚virtual void HepLCIOInterface::GeneratePrimaryVertex(G4Event*)‚:
src/HepLCIOInterface.cc:278: error: ‚assert‚ was not declared in this scope
/afs/desy.de/i586_rhel40/products/CLHEP/2.0.3.2/include/CLHE P/Units/PhysicalConstants.h: At global scope:
/afs/desy.de/i586_rhel40/products/CLHEP/2.0.3.2/include/CLHE P/Units/PhysicalConstants.h:78: warning: ‚CLHEP::electron_charge‚ defined but not used
make[1]: *** [/mnt/data2/ilcsoft/v01-06/Mokka/mokka-06-07-patch01/tmp/Lin ux-g++/Mokka/HepLCIOInterface.o] Error 1
make[1]: Leaving directory `/mnt/data2/ilcsoft/v01-06/Mokka/mokka-06-07-patch01/source/ Kernel'
make: *** [all] Error 2
*** ERROR in module [ Mokka ]: Required file not found: ['/mnt/data2/ilcsoft/v01-06/Mokka/mokka-06-07-patch01/bin/Li nux-g++/Mokka']

and If I go to the directory '/mnt/data2/ilcsoft/v01-06/Mokka/mokka-06-07-patch01/bin/" it is empty.

I have tried to put in the configuration file the line that you told me:
ilcsoft.module( "Mokka").download.type="cvs"

But I obtain again the same error message about Mokka.
Re: problems with mokka in v01-04 [message #1882 is a reply to message #1768] Wed, 30 September 2009 00:51 Go to previous messageGo to next message
iglesias
Messages: 18
Registered: November 2008
Location: Universidad de Santiago (...

Sorry, I have not read this mail because in June I was with maternity leave.
Now I unset the enviorement variable as you told me and re-compile Mokka and I have finished correctly the installation.

Thank you very much.

Regards

Carmen
Re: problems with mokka in v01-04 [message #1883 is a reply to message #1882] Wed, 30 September 2009 00:56 Go to previous message
engels
Messages: 106
Registered: August 2006
Hi Carmen,

No problem, I'm glad I could help Smile

Cheers,
Jan
Previous Topic:problem in the installation of MOKKA
Next Topic:Simulator status of particles in MC collection
Goto Forum:
  

[ PDF ]

Current Time: Wed Nov 20 09:30:20 Pacific Standard Time 2019
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.1.
Copyright ©2001-2010 FUDforum Bulletin Board Software