Linear Collider Forum



Home » Software Tools » LCIO » LCIO install error
LCIO install error [message #1923] Thu, 01 April 2010 06:40 Go to next message
Ryan_Page
Messages: 18
Registered: October 2008
Location: Bristol/RAL
Hi,

I am trying to install lcio and have hit a problem. It started because I did not have zlib installed but after i installed it I tried to install lcio again and it gave this error:

/exports/gpfs/phrfp/products_32/zlib-1.2.4/lib/libz.so: could not read symbols: File in wrong format

The version of zlib is new, from what I can tell it was released this month. Has anyone else run into this problem, any suggestions would be very welcome!

I am running on this system

Linux - Scientific Linux SL release 4.3 (Beryllium) , gcc (GCC) 3.4.6

Thanks

Ryan

Re: LCIO install error [message #1929 is a reply to message #1923] Tue, 06 April 2010 03:01 Go to previous messageGo to next message
engels
Messages: 106
Registered: August 2006
Hi Ryan,

the problem seems to be a 32/64 bit incompatibility between LCIO and the libz.so installed on your system.

LCIO is built per default in 32 bit (even on 64 bit platforms)
There is a cmake flag called BUILD_32BIT_COMPATIBLE (set to ON per default) which you can turn off to build LCIO in native 64 bit, i.e.:

cmake -DBUILD_32BIT_COMPATIBLE=OFF ..

you can easily check if your libz.so is 32 or 64 bit with:
file $(readlink -f /exports/gpfs/phrfp/products_32/zlib-1.2.4/lib/libz.so)

Cheers,
Jan
Re: LCIO install error [message #1930 is a reply to message #1929] Tue, 06 April 2010 03:38 Go to previous messageGo to next message
Ryan_Page
Messages: 18
Registered: October 2008
Location: Bristol/RAL
Thanks, the version I have is 64bit. I have changed env variables CMAKE_LIBRARY_PATH and CMAKE_INCLUDE_PATH to the dir that contains the 32 bit version of zlib, but now cmake can not find it, are there any other variable that I should be setting?

Thanks

Ryan
Re: LCIO install error [message #1932 is a reply to message #1930] Tue, 06 April 2010 05:11 Go to previous messageGo to next message
engels
Messages: 106
Registered: August 2006
Hi Ryan,

this may happen because cmake stores configurations in a file called CMakeCache.txt inside your build directory.

Please erase that file, set the env vars CMAKE_LIBRARY_PATH and CMAKE_INCLUDE_PATH and re-run cmake, it should then find your 32 bit zlib.

Cheers,
Jan
Re: LCIO install error [message #1933 is a reply to message #1932] Tue, 06 April 2010 05:52 Go to previous messageGo to next message
Ryan_Page
Messages: 18
Registered: October 2008
Location: Bristol/RAL
Hi,

Thanks, I tried that sadly to know affect. In the configuration file i have set the following

ilcsoft.env["CMAKE_LIBRARY_PATH"]="/usr/lib"
ilcsoft.env["CMAKE_INCLUDE_PATH"]="/usr/include"
ilcsoft.env["ZLIB_LIBRARY"]="/usr/lib/libz.so.1.2.1.2"
ilcsoft.env["ZLIB_INCLUDE_PATH"]="/usr/include"

I have also tried setting these using export, but I still have the same problem.

Is there another cache somewhere or another variable that I can play with?

Re: LCIO install error [message #1934 is a reply to message #1933] Tue, 06 April 2010 06:08 Go to previous messageGo to next message
engels
Messages: 106
Registered: August 2006
ok, could you please send me your ilcinstall configuration file?

Thanks,
Jan
Re: LCIO install error [message #1935 is a reply to message #1934] Tue, 06 April 2010 06:41 Go to previous messageGo to next message
Ryan_Page
Messages: 18
Registered: October 2008
Location: Bristol/RAL
Hi,

Here it is.

Thanks

Re: LCIO install error [message #1937 is a reply to message #1935] Tue, 06 April 2010 08:23 Go to previous messageGo to next message
engels
Messages: 106
Registered: August 2006
Hi Ryan,

if I understand correctly you have a 32bit version of zlib installed in
/exports/gpfs/phrfp/products_32/zlib-1.2.4

if this is true than what you want in your ilcinstall configuration file is:

# find 32bit zlib in /exports/gpfs/phrfp/products_32/zlib-1.2.4
zlib_32bit_path="/exports/gpfs/phrfp/products_32/zlib-1.2.4"
ilcsoft.env["CMAKE_LIBRARY_PATH"]=zlib_32bit_path+"/lib"
ilcsoft.env["CMAKE_INCLUDE_PATH"]=zlib_32bit_path+"/include"

please find the modified configuration file attached in this message.


since cmake stores the paths in the CMakeCache.txt you should first remove the file:
rm /exports/gpfs/phrfp/ilcsoft_32/base/lcio/v01-12-02/build/CMakeCache.txt


and then re-run ilcinstall with the attached cfg file.

P.S. there is already a newer patch release of ilcsoft (v01-08-01) which contains important bug fixes.
Please find more details here and the newer ilcinstall version here


Cheers,
Jan

Re: LCIO install error [message #1938 is a reply to message #1937] Wed, 07 April 2010 08:07 Go to previous message
Ryan_Page
Messages: 18
Registered: October 2008
Location: Bristol/RAL
Hi,

I have made some changes to the sym links for zlib and that seems to have fixed the problem.

Thanks very much for your help

Ryan
Previous Topic:Error Using LCIOWriter
Next Topic:TrackerHitImpl const-ness of setPosition
Goto Forum:
  

[ PDF ]

Current Time: Sun Oct 13 17:37:06 Pacific Daylight Time 2019
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.1.
Copyright ©2001-2010 FUDforum Bulletin Board Software