Linear Collider Forum



Home » ILCDirac » Applications » policy for ilcsoft updates in ilcdirac
policy for ilcsoft updates in ilcdirac [message #2292] Thu, 19 December 2013 17:34 Go to next message
jeans
Messages: 22
Registered: November 2012
Dear all,

Could you tell me what the policy for including recent ilcsoft releases in ilcdirac is?

Since we would like to run CALICE software using the system, this information would help us to decide some policy on which ilcsoft version to build our software against.

Thanks,
Daniel.
Re: policy for ilcsoft updates in ilcdirac [message #2293 is a reply to message #2292] Thu, 19 December 2013 23:37 Go to previous message
cgrefe
Messages: 1
Registered: October 2008
Location: CERN
Dear Daniel,

so far we have simply added software versions upon request (within reason), since this requires to package the software into a tar ball. In the future, once we have moved to using CVMFS for our software installations, I expect that all ILCSOFT versions will be available.

With the current software tar balls we advise to download the respective software version from the grid (/ilc/prod/software/) and build your software against that using plain SLC5, i.e. gcc 4.1 (although SLC6 - gcc 4.4, should now be used on most sites).

The CALICE software could of course be included into the available packages if this is useful for you.

Cheers,
Christian
Previous Topic:help getting started with Mokka in ILCDIRAC
Next Topic:Changing detector geometry in ILCDirac
Goto Forum:
  

[ PDF ]

Current Time: Tue Nov 12 18:34:43 Pacific Standard Time 2019
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.1.
Copyright ©2001-2010 FUDforum Bulletin Board Software