Linear Collider Forum



Home » Analysis and Reconstruction » Tracking & Vertexing » problem on LCFIVertex with LCFIAIDAPlotProcessor
problem on LCFIVertex with LCFIAIDAPlotProcessor [message #1412] Thu, 28 February 2008 03:23 Go to previous message
satoru
Messages: 3
Registered: July 2007
Location: Kobe University, Japan
Hello,

I am using ilcsoft on KEK machine (which I have installed),
and now try to run LCFIVertex.
I would like to use LCFIAIDAPlotProcessor, so I tried to compile it with AIDAJNI aidajni-3.2.6 and jdk1.5.0_12.
After doing cmake as documented in LCFIVertex reference manual,
make seems to be successful.
But when I try to run with the compiled library, I got following errors from Marlin:

<!-- ERROR loading shared library : /home/uozumis/ilcsoft/LCFIVertex/HEAD/lib/libLCFIVertex.so
-> /home/uozumis/ilcsoft/LCFIVertex/HEAD/lib/libLCFIVertex.so: undefined symbol: _ZNSt24__default_alloc_templateILb1ELi0EE8allocateEj -->

ProcessorMgr::registerProcessor: unknown processor with type Plot !
ProcessorMgr::registerProcessor: unknown processor with type LCFIAIDAPlotProcessor !

I tried to change the java version to j2sdk1.4.2_12, but it doesn't work.
Could I have some helps on it if you have any idea?

Thank you very much,
- Satoru Uozumi
Kobe University
 
Read Message
Read Message
Read Message
Previous Topic:MarlinTPC: TPCHit
Next Topic:Default Analyses in MarlinTPC
Goto Forum:
  


Current Time: Sat Dec 15 15:21:15 Pacific Standard Time 2018
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.1.
Copyright ©2001-2010 FUDforum Bulletin Board Software