Linear Collider Forum



Home » Analysis and Reconstruction » Tracking & Vertexing » problem on LCFIVertex with LCFIAIDAPlotProcessor
Re: problem on LCFIVertex with LCFIAIDAPlotProcessor [message #1413 is a reply to message #1412] Thu, 28 February 2008 11:25 Go to previous messageGo to previous message
vogel
Messages: 83
Registered: March 2005
Location: DESY, Hamburg, Germany
Dear Satoru,

I encountered a similar problem (“Error loading shared library: undefined symbol”) which was related to Gear: I had built the main Marlin executable without Gear support, but one of my processors in another software package was automatically built with Gear. When I tried to run Marlin with the external library, a global object was missing from the main executable. It helped to re-build the main Marlin executable with “BUILD_WITH=GEAR”.

Since you are using AIDAJNI, maybe you could try to re-build your main Marlin executable with “BUILD_WITH=AIDAJNI” (plus possibly other modules which you also need, like Gear or whatever). Either run “cmake” with the command line option “-DBUILD_WITH="AIDAJNI GEAR ..."” or edit your CMake cache with the “ccmake” tool and add “AIDAJNI” to the line “BUILD_WITH” (you need to toggle to advanced mode to see this). If you find “RAIDA” there, I suppose you should remove it.

Without knowing how AIDAJNI exactly works, I think this kind of problem should not be related to your Java version in any way.

This is just a guess, but maybe it helps.
Adrian
 
Read Message
Read Message
Read Message
Previous Topic:MarlinTPC: TPCHit
Next Topic:Default Analyses in MarlinTPC
Goto Forum:
  


Current Time: Tue Jun 19 18:41:17 Pacific Daylight Time 2018
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.1.
Copyright ©2001-2010 FUDforum Bulletin Board Software