Linear Collider Forum



Home » Analysis and Reconstruction » Analysis Tools » Efficiency plot using AIDA
Efficiency plot using AIDA [message #1509] Tue, 17 June 2008 17:38 Go to previous message
partridge
Messages: 11
Registered: October 2005
I am trying to make some efficiency plots, but am running into a couple problems.

The Aida documentation indicates that there is a "type=efficiency" option for histograms, which is what I am trying to use.

The first problem is pretty trivial: the defaultInstance class in org.lcsim does not have a method that allows the option string to be passed.

The first problem can be bypassed by using the histogramFactory method to directly create the histogram. While I couldn't find any documentation on how to fill an efficiency histogram, using the fill method with a weight of 1 for passing entries and 0 when you have an inefficient entry seems to give a reasonable looking efficiency plot.

This brings me to the second problem, namely that the errors do not appear to be the expected binomial errors. I calculated a few bins by hand, and it looked like the errors were about a factor of 2 too big in those cases. There were some bins with low efficiency where the discrepancy looked to be even worse.

Just for the record, my expectation is that the error in an efficiency bin with npass call out of ntot total calls will be:

sigma = sqrt(npass * (ntot - npass) / ntot).
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic:JAS3 classpath question/trying to get trivalPFA to compile
Next Topic:Fitting histograms with other histograms
Goto Forum:
  


Current Time: Wed Sep 19 21:20:03 Pacific Daylight Time 2018
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.1.
Copyright ©2001-2010 FUDforum Bulletin Board Software