Linear Collider Forum



Home » Software Tools » Marlin et al » requirements for using ILC software with full simulation
Re: requirements for using ILC software with full simulation [message #1630 is a reply to message #1629] Tue, 25 November 2008 05:43 Go to previous messageGo to previous message
iglesias
Messages: 18
Registered: November 2008
Location: Universidad de Santiago (...

Hello Martin:
Here I attached my new version of the installation file (my_install_v01-04.cfg)

I have set ilcsoft to my local directory that I want to use:
ilcsoft= ILCSoft("/mnt/data2/ilcsoft/ilcinstall_prueba/ilcinstall/my_v01-04 ")
But I'm not sure about if I have to set also ilcPath to my local directory or only put:
ilcPath = "/afs/desy.de/group/it/ilcsoft/"
is it wrong?

I have put "use" option:
- and specify the path for ROOT, Geant4, CondDBMySQL, CMakeModules and Gear, because I have them in /mnt/data2/ilc directory, download and compile bymyself.
- and specified "/usr", for MySql, CMake, QT, GSL and CernLib as they are in /usr/bin/ or /usr/lib, and this is found by ilcinstall.
Is that OK?

But I have different versions in QT and in MySql:
- QT is 3.3 instead of 4.2.2
- MySql is 5.0.45 instead of 5.0.26
is this a problem?

Y have put "install" option for LCIO, Marlin, CED, LCCD, RAIDA, MOKKA and some Marlin Packages (CEDViewer, LCFIVertex, Overlay, EUTelescope, MarlinTPC, MarlinReco, MarlinUtil and PandoraPFA).

You told me that I must uncomment all packages I don't need to prevent possible compile problems, but I'm not sure about what packages I will need. . I’m very interested in the study the role of the FTD geometry in the energy resolution of jets in the forward region using PandoraPFA to reconstruct jets wich pass throught VTX,FTP, TPC, ETD and ECAL endcap using the actual ILD geometry.What packages will be needed?

Finally I can't install JAVA because I have SL5, What can I do to get JAVA?.

 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic:MarlinTPC processor apparently fails to install
Next Topic:new ilcsoft release v01-05-02
Goto Forum:
  


Current Time: Mon Oct 14 14:13:28 Pacific Daylight Time 2019
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.1.
Copyright ©2001-2010 FUDforum Bulletin Board Software