Linear Collider Forum



Home » General » General Questions » Class not found
Re: Class not found [message #1752 is a reply to message #1749] Tue, 02 June 2009 11:17 Go to previous messageGo to previous message
bweinert
Messages: 16
Registered: September 2008
Location: University of Rochester
Hi, I commented out the top line and added all the import statements to get the program to compile. It compiles and it runs, but the loop terminates due to error early on in the program. It says:

java.lang.IllegalArgumentException: Unknown event component Tracks
at hep.physics.event.BaseEvent.get(BaseEvent.java:48)
at org.lcsim.event.base.BaseLCSimEvent.get(BaseLCSimEvent.java: 100)
at org.lcsim.event.base.BaseLCSimEvent.getTracks(BaseLCSimEvent .java:80)
at MuonReco.process(MuonReco.java:74)
at org.lcsim.util.DriverAdapter.recordSupplied(DriverAdapter.ja va:74)
at org.freehep.jas.extensions.recordloop.MyChain.recordSupplied (MyChain.java:55)
at org.freehep.jas.extensions.recordloop.InteractiveRecordLoop. supplyRecord(InteractiveRecordLoop.java:533)
at org.freehep.jas.extensions.recordloop.RecordLoopManager.run( RecordLoopManager.java:66)
at java.lang.Thread.run(Unknown Source)

How would I go about fixing this error, is there a problem with all of the programs that MuonReco calls?

Also, it seemed like there was some confusion about what I was trying to do with this code. I was under the impression that I should execute this code in JAS3. Is this wrong, is this code supposed to be run in something else or is it just batch code? Thank you for your help.

-Ben
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic:SLIO file
Next Topic:IDDecoder
Goto Forum:
  


Current Time: Thu Jul 19 23:37:47 Pacific Daylight Time 2018
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.1.
Copyright ©2001-2010 FUDforum Bulletin Board Software