Linear Collider Forum



Home » Software Tools » org.lcsim » Failing to run tutorial: Processing Data in Batch Mode using LCSim XML
Re: Failing to run tutorial: Processing Data in Batch Mode using LCSim XML [message #1840 is a reply to message #1839] Fri, 21 August 2009 14:08 Go to previous messageGo to previous message
jeremy
Messages: 46
Registered: March 2004
Location: SLAC
Hans,

The command you're using is (slightly) wrong. It should be...

java -jar ./target/lib/lcsim-1.11.jar ./myJob.xml

This is somewhat subtle, but you need to run the copy in the lib dir instead of the one in target. This is because the maven build places all of lcsim's dependencies into the ./target/lib dir, and when you run from ./target/lcsim-1.11.jar, it can't find the dependencies because it uses the relative path to find them.

You can also take the deps zip file and run it someplace else, which might be less confusing.

cd /myworkdir
cp /my/lcsim/target/lcsim-1.11-deps.zip .
unzip lcsim-1.11-deps.zip
java -jar ./lib/lcsim-1.11.jar myJob.xml

The above is how I typically tend to run it.

Here are the general instructions for running from batch.

http://confluence.slac.stanford.edu/display/ilc/lcsim+xml

Let me know if either of these suggestions works for you.


Jeremy McCormick, SLAC <jeremym@slac.stanford.edu>
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic:lcsim release
Next Topic:How can I access the current input file from within the lcsim
Goto Forum:
  


Current Time: Fri Jan 19 15:12:05 Pacific Standard Time 2018
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.1.
Copyright ©2001-2010 FUDforum Bulletin Board Software