Linear Collider Forum



Home » Software Tools » LCIO » Error Using LCIOWriter
Error Using LCIOWriter [message #1924] Fri, 02 April 2010 10:06 Go to previous message
alex.bogert
Messages: 3
Registered: December 2008
Hello,

I am trying to create a .lcio file from a .stdhep file using org.lcsim.util.lcio.LCIOWriter. I am adding a few sub-collections of MCParticles to the EventHeader then using LCIOWriter to write out the event. When I look at the resulting .lcio file in JAS3 a large number of events give a NullPointerException. I have recreated the .lcio file several times and the null events seemed to be randomly distributed amongst the 1000 events in the file. I have also tried flushing the LCIOWriter after each write, this causes no change in behavior. Any suggestions how I could resolve this issue? On average I'm losing about 30% of the events to NullPointerExceptions. Also, I've printed out event information just before Writing and the events are not null.

Edit: I removed the sub-collection of MCParticles from the list of collection for LCIOWriter to write out. This seems to fix the Null events. I would still like to be able to write out sub-collections.

Thanks,
Alex

[Updated on: Sat, 03 April 2010 09:03]

 
Read Message
Read Message
Read Message
Previous Topic:Segmentation violation when copying ParticleIDs of ReconstructedParticle
Next Topic:LCIO install error
Goto Forum:
  


Current Time: Fri Nov 16 16:44:56 Pacific Standard Time 2018
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.1.
Copyright ©2001-2010 FUDforum Bulletin Board Software