Linear Collider Forum



Home » Software Tools » LCIO » LCIO install error
Re: LCIO install error [message #1929 is a reply to message #1923] Tue, 06 April 2010 03:01 Go to previous messageGo to previous message
engels
Messages: 106
Registered: August 2006
Hi Ryan,

the problem seems to be a 32/64 bit incompatibility between LCIO and the libz.so installed on your system.

LCIO is built per default in 32 bit (even on 64 bit platforms)
There is a cmake flag called BUILD_32BIT_COMPATIBLE (set to ON per default) which you can turn off to build LCIO in native 64 bit, i.e.:

cmake -DBUILD_32BIT_COMPATIBLE=OFF ..

you can easily check if your libz.so is 32 or 64 bit with:
file $(readlink -f /exports/gpfs/phrfp/products_32/zlib-1.2.4/lib/libz.so)

Cheers,
Jan
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic:Error Using LCIOWriter
Next Topic:TrackerHitImpl const-ness of setPosition
Goto Forum:
  


Current Time: Fri Jun 22 19:16:22 Pacific Daylight Time 2018
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.1.
Copyright ©2001-2010 FUDforum Bulletin Board Software