Linear Collider Forum



Home » Analysis and Reconstruction » Tracking & Vertexing » building LCFIVertex with AIDAJNI
building LCFIVertex with AIDAJNI [message #2078] Wed, 29 September 2010 14:15
voutsi
Messages: 9
Registered: November 2009
Hello,

I want to build LCFIVertex package with AIDAJNI. I have ilcsoft version 01-08-01 so trying to install AIDAJNI 3.2.3 there using ilcsoft-install. It says that build is successful

BUILD SUCCESSFUL
Total time: 7 seconds
sh: gmake: command not found
sh: gmake: command not found
Traceback (most recent call last):
File "/var/autofs/nfs/rawcmos11/voutsi/v01-08-01/ilcsoft-install", line 72, in ?
ilcsoft.makeinstall()
File " /var/autofs/nfs/rawcmos11/voutsi/v01-08-01/ilcsoft/ilcsoft.p y ", line 423, in makeinstall
mod.install([])
File " /var/autofs/nfs/rawcmos11/voutsi/v01-08-01/ilcsoft/baseilc.p y ", line 758, in install
self.compile()
File " /var/autofs/nfs/rawcmos11/voutsi/v01-08-01/ilcsoft/aidajni.p y ", line 71, in compile
os.system( 'tar -xzf %s-%s-'+self.os_ver.type+'-g++.tar.gz' % (self.alias, self.version) )
TypeError: not all arguments converted during string formatting

So I don't really understand if is successful or not. Then trying to build LCFIVertex with
AIDAJNI and

-- Check for AIDAJNI: /rawcmos11/voutsi/ilcsoft/AIDAJNI/3.2.3
-- Java version 1.6.0 configured successfully!
-- Check for JAIDA: /rawcmos11/voutsi/ilcsoft/JAIDA/3.2.3 -- works
-- Check for AIDAJNI: /rawcmos11/voutsi/ilcsoft/AIDAJNI/3.2.3 -- failed to find AIDAJNI AIDAJNI library!!
-- Check for AIDAJNI: /rawcmos11/voutsi/ilcsoft/AIDAJNI/3.2.3 -- failed to find AIDAJNI FHJNI library!!
CMake Error at /rawcmos11/voutsi/ilcsoft/CMakeModules/v01-08-01/FindAIDAJNI .cmake:234 (MESSAGE):
Check for AIDAJNI: /rawcmos11/voutsi/ilcsoft/AIDAJNI/3.2.3 -- failed!!
Call Stack (most recent call first):
/rawcmos11/voutsi/ilcsoft/CMakeModules/v01-08-01/MacroLoadPa ckage.cmake:103 (FIND_PACKAGE)
/rawcmos11/voutsi/ilcsoft/CMakeModules/v01-08-01/MacroCheckD eps.cmake:36 (LOAD_PACKAGE)
CMakeLists.txt:267 (CHECK_DEPS)

So seems like something went wrong at AIDAJNI install.. Have already install java and JAIDA. The path to the AIDAJNI library is also defined correctly.

Any comment is very welcomed,

Thanks a lot

Yorgos
 
Read Message
Previous Topic:Problem on new trunk version r2253
Next Topic:Measurement of Impact parameter
Goto Forum:
  


Current Time: Tue Dec 18 11:03:57 Pacific Standard Time 2018
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.1.
Copyright ©2001-2010 FUDforum Bulletin Board Software