Linear Collider Forum



Home » Simulation » Mokka » Problem with installing Mokka (Mokka installation stops with an error when linking)
Problem with installing Mokka [message #2173] Wed, 22 June 2011 02:19 Go to previous message
Robin
Messages: 4
Registered: June 2011
Location: Vienna
Hi everyone,

Maybe someone knows this problem and can help me.

I tried to install Mokka on my SL5 (64Bit) mashine, but it always stops with an error when linking.

I am using:

CLHEP: 2.0.4.5
GEANT4: 9.3.p02
g++: 4.1.2


This is my environment:

CLHEP_LIB_DIR=/usr/local/lib
G4LEVELGAMMADATA=/opt/geant4/9.3.p02/data/PhotonEvaporation2 .0
GEAR=/scratch/ilcsoft/v01-11/gear/v00-17
SSH_AGENT_PID=3272
HOSTNAME=hdpc049.hephy.local
DESKTOP_STARTUP_ID=
G4INSTALL=/opt/geant4/9.3.p02
TERM=xterm
SHELL=/bin/bash
HISTSIZE=1000
KDE_NO_IPV6=1
G4VIS_BUILD_VRML_DRIVER=1
GTK_RC_FILES=/etc/gtk/gtkrc:/home/robin/.gtkrc-1.2-gnome2
WINDOWID=24117328
LCIO=/scratch/ilcsoft/v01-11/lcio/v01-51-02
OLDPWD=/scratch/ilcsoft/v01-11/Mokka/mokka-07-06-p02/source
QTDIR=/usr/lib64/qt-3.3
QTINC=/usr/lib64/qt-3.3/include
G4LEDATA=/opt/geant4/9.3.p02/data/G4EMLOW6.9
USER=robin
LD_LIBRARY_PATH=/opt/CLHEP/2.1.0.1/CLHEP
XMFLAGS=
XMLIBS=
G4NEUTRONHPDATA=/opt/geant4/9.3.p02/data/G4NDL3.13
SSH_AUTH_SOCK=/tmp/ssh-sUQHBD3233/agent.3233
KDEDIR=/usr
SESSION_MANAGER=local/hdpc049.hephy.local:/tmp/.ICE-unix/323 3
G4RADIOACTIVEDATA=/opt/geant4/9.3.p02/data/RadioactiveDecay3 .2
G4ABLADATA=/opt/geant4/9.3.p02/data/G4ABLA3.0
PATH=/usr/lib64/qt-3.3/bin:/usr/kerberos/bin:/usr/local/bin: /usr/bin:/bin:/usr/X11R6/bin:/home/robin/bin
G4VIS_USE_DAWN=1
G4LIB=/opt/geant4/9.3.p02/lib
G4VIS_BUILD_RAYTRACERX_DRIVER=1
QT_IM_MODULE=scim
GDM_XSERVER_LOCATION=local
G4LIB_BUILD_SHARED=1
INPUTRC=/etc/inputrc
PWD=/
XMODIFIERS=@im=SCIM
G4LIB_BUILD_STATIC=1
CLHEP_BASE_DIR=/usr/local
KDE_IS_PRELINKED=1
LANG=en_US.UTF-8
PS1=\u@\h \w $
G4LIB_BUILD_ZLIB=1
GDMSESSION=default
SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
G4UI_USE_TCSH=1
G4LIB_USE_GRANULAR=1
G4VIS_USE_RAYTRACERX=1
CLHEP_INCLUDE_DIR=/usr/local/include
SHLVL=2
G4DEBUG=1
G4REALSURFACEDATA=/opt/geant4/9.3.p02/data/RealSurface1.0
G4SYSTEM=Linux-g++
GNOME_DESKTOP_SESSION_ID=Default
XAWLIBS=
LOGNAME=robin
QTLIB=/usr/lib64/qt-3.3/lib
CVS_RSH=ssh
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-CqdPWfbnA8, guid=bf37293bcad3239758f0c5004e01ad2e
G4VIS_BUILD_DAWN_DRIVER=1
G4VIS_USE_VRML=1
CLHEP_LIB=CLHEP
GTK_IM_MODULE=scim-bridge
XAWFLAGS=
G4LIB_USE_ZLIB=1
G_BROKEN_FILENAMES=1
COLORTERM=gnome-terminal



And here comes the ERROR:

Compiling Visu.cc ...
Compiling VisuMessenger.cc ...
Creating shared library /opt/geant4/9.3.p02/tmp/Linux-g++/Mokka/libMokka.so ...
Creating/replacing object files in /opt/geant4/9.3.p02/tmp/Linux-g++/Mokka/libMokka.a ...
ar: creating /opt/geant4/9.3.p02/tmp/Linux-g++/Mokka/libMokka.a
Compiling Mokka.cc ...
Using granular libraries ...
Linking Mokka
/opt/geant4/9.3.p02/tmp/Linux-g++/Tesla/libTesla.so: undefined reference to `Yoke05::BuildRPC1PlugShape(G4Polyhedra*, muonSD*, int, G4UserLimits*, Database*, CGAGeometryEnvironment const&)'
collect2: ld returned 1 exit status
gmake[1]: *** [/opt/geant4/9.3.p02/bin/Linux-g++/Mokka] Error 1
gmake[1]: Leaving directory `/scratch/ilcsoft/v01-11/Mokka/mokka-07-06-p02/source/Kernel '
gmake: *** [all] Error 2



If you need any furhter detail, please let me know.

With kind regards, Robin Glattauer (Hephy Vienna)

 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic:mokka "skip events" from stdhep input?
Next Topic:Mokka Simulation Times
Goto Forum:
  


Current Time: Fri Jan 19 09:28:07 Pacific Standard Time 2018
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.1.
Copyright ©2001-2010 FUDforum Bulletin Board Software