Linear Collider Forum

Home » Software Tools » Marlin et al » Installation of ilcsoft v01-17-03 - Bug in DD4hep installation?! (DD4hep installation vulnerable to user environment)
Re: Installation of ilcsoft v01-17-03 - Bug in DD4hep installation?! [message #2282 is a reply to message #2277] Tue, 29 October 2013 07:51 Go to previous message
Messages: 41
Registered: March 2009
Hi Roman,

coming back to the original problem:

poeschl wrote on Wed, 16 October 2013 09:20
[...]It appears that the FindROOT.cmake in dd4hep finds my system wide root installation, which indeed doesn't contain the requested include files (why not is my problem but this doesn't matter here). When installed from *scratch* dd4hep should however always use the root version which got installed through the corresponding ilcinstall scripts.
I think one has to remedy this vulnerability, i.e. the FindROOT.cmake has somehow to be told which root version to use instead of starting to search on its own. It is very likely that on a system an additional root version is installed.


This /shouldn't/ be any problem, so I still don't completely understand how this is happening.

Citing from the cmake documentation: Quote:
CMake searches for a file called "Find<package>.cmake" in the CMAKE_MODULE_PATH followed by the CMake installation

So if you've set/extended the CMAKE_MODULE_PATH prior to calling the individual installation, then the ROOT version specified there is used. If you use the ilcinstall method, this is done automatically.

The following explanations come to my mind:
- you didn't install ROOT with ilcinstall
- there is a bug with your specific CMake version (which is not unheard of)

If you could provide me please (directly or pointers):
- the install config file (
- the OS


When you have eliminated the impossible, whatever remains, however improbable, must be the truth. (Sir A.C. Doyle in Sign of Four)
Read Message warning.gif
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic:new ilcsoft developers release v01-17-04
Next Topic:new ilcsoft developers release v01-17-05
Goto Forum:

Current Time: Thu Mar 22 06:52:15 Pacific Daylight Time 2018
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.1.
Copyright ©2001-2010 FUDforum Bulletin Board Software