Linear Collider Forum



Home » Analysis and Reconstruction » Reconstruction » Bug in MarlinReco/PFOID/src/Histogram.cc
Re: Bug in MarlinReco/PFOID/src/Histogram.cc [message #2311 is a reply to message #2310] Fri, 25 April 2014 02:48 Go to previous messageGo to previous message
sailer
Messages: 34
Registered: February 2009
Hi Beata,

I wanted to say the issue has been fixed, but actually only in a different function. https://svnsrv.desy.de/viewvc/marlinreco/MarlinReco/tags/v01 -09/PFOID/src/Histogram.cc?annotate=1445
(I don't even know if this change is due to this post of because someone else encountered the bug themselves...)
So the bug still exists and it seems you stumbled across it as well.

If you are using your own installation of Marlin you could just fix the bug in your installation.

Just add the line
 if ( mind<0 ) mind = 0;

after line 358 and before line 360 into the MarlinReco/PFOID/src/Histogram.cc
and then recompile and install MarlinReco

make sure to source the ILCSOFT environment
cd MarlinReco/<VERSION>/build ## this folder should exist already
make install

If you are not using your own installation, which installation of Marlin are you using?

And we should make sure this is fixed in the new version of MarlinReco. Though I still don't understand when this bug shows up and the "mind=0" cures the symptom but not the disease.

Cheers,
Andre
 
Read Message
Read Message
Read Message
Read Message
Previous Topic:collection not in event:TPCSpacePointCollection
Next Topic:Problem with Marlin
Goto Forum:
  


Current Time: Wed Oct 17 06:28:02 Pacific Daylight Time 2018
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.1.
Copyright ©2001-2010 FUDforum Bulletin Board Software