Linear Collider Forum



Home » Software Tools » Marlin et al » iLCSoft release v01-17-06
Re: iLCSoft release v01-17-06 [message #2353 is a reply to message #2318] Tue, 03 February 2015 03:42 Go to previous messageGo to previous message
grenier
Messages: 13
Registered: June 2008
Location: LYON
Dear all,

I'm trying to install that release on my ubuntu 12.04 machine.

It fails in ROOT installation not finding Python which is installed on the machine.

I've run
./ilcsoft-install -i releases/v01-17-06/release-ubuntu-base.cfg

and I got :

############################################################ ####################
##### Compiling ROOT version 5.34.18...
############################################################ ####################

...
...

Checking for Python.h ... no
Checking for python2.7, libpython2.7, libpython, python, or Python ... no
Explicitly required Python dependencies not fulfilled

*** ERROR in module [ ROOT ]: DEBUG INFO: {'PLATFORM': 'Linux - Ubuntu 12.04.5 LTS', 'GCC_VERSION': 'gcc (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3', 'LSB_RELEASE': 'Distributor ID:\tUbuntu\nDescription:\tUbuntu 12.04.5 LTS\nRelease:\t12.04\nCodename:\tprecise', 'UNAME': 'Linux lyopc608 3.5.0-54-generic #81~precise1-Ubuntu SMP Tue Jul 15 04:02:22 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux'}

*** ERROR in module [ ROOT ]: failed to configure!!


However, when I execute locate libpython2.7, I got
/usr/lib/libpython2.7.so.1
/usr/lib/libpython2.7.so.1.0
/usr/lib/python2.7/config/libpython2.7.so
/usr/share/doc/libpython2.7
/usr/share/lintian/overrides/libpython2.7
/var/cache/apt/archives/libpython2.7_2.7.3-0ubuntu3.6_amd64. deb
/var/lib/dpkg/info/libpython2.7.list
/var/lib/dpkg/info/libpython2.7.md5sums
/var/lib/dpkg/info/libpython2.7.postinst
/var/lib/dpkg/info/libpython2.7.postrm
/var/lib/dpkg/info/libpython2.7.shlibs
/var/lib/dpkg/info/libpython2.7.symbols


So the right python is installed.


Any clue on how to solve this issue ?

Regards
 
Read Message
Read Message
Read Message
Read Message yes.gif
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic:CMake with local package
Next Topic:crash when compiling DD4hep in ILCSoft-01-17-6
Goto Forum:
  


Current Time: Mon Jan 22 04:26:31 Pacific Standard Time 2018
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.1.
Copyright ©2001-2010 FUDforum Bulletin Board Software