Linear Collider Forum

Home » Software Tools » Marlin et al » iLCSoft release v01-17-09
Re: iLCSoft release v01-17-09: centOS7 installation report [message #2390 is a reply to message #2380] Thu, 17 March 2016 23:57 Go to previous message
Messages: 22
Registered: November 2012
Hello ilcsofters,

I've installed v01-17-09 on CentOS7:
"CentOS Linux release 7.2.1511 (Core)
Derived from Red Hat Enterprise Linux 7.2 (Source)"
gcc version 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC)

I ran into a few small problems which prevented it from being a totally pain-free experience. I post them here in case they are useful for others.

1) I gave up trying to compile and install CERNLIB, it did not seem to want to compile with gfortran...

This required a couple of changes to release-ilcsoft.cfg:

ignore fortran parts of MarlinReco
ilcsoft.install( MarlinReco( MarlinReco_version )) 
# the following means we don't need cernlb

and turn off FastJetClustering.

2) my dual core laptop froze completely during installation: change to

in release-ilcsoft.cfg to compile serially.
The stages of "Building CXX object DDCore/CMakeFiles/DDCore.dir/src/parsers/ParsersStandard*" in particular seem to require a lot of memory.

3) Then I bumped into a problem when compiling DD4hep.
I already had ftgl installed on my system, which meant that the root installation did not compile it's own internal version of this package. The root version of the library is called, while the "native" one is DD4hep looks for -lFTGL, and therefore didn't find the native library.
I fixed this by removing ftgl from the system and reinstalling/compiling root, forcing it to install its own version.

4) added following to release-ilcsoft.cfg for c++11:
ilcsoft.module("MarlinPandora").envcmake["CMAKE_CXX_FLAGS"]='-std=c++11 -Wall'
ilcsoft.module("PandoraPFANew").envcmake["CMAKE_CXX_FLAGS"]='-std=c++11 -Wall'

I'm not sure both were needed, but it did the trick.
(I had set
use_cpp11 = False


5) KalTest tried to build against "native" root (i.e. the one I had installed via "yum install root*") installation, rather than version installed during ilcsoft base installation. Removing the "native" version fixed it.

Now all seems OK.
Read Message
Read Message
Previous Topic:DDG4 particle gun
Next Topic:running CED on output of lcgeo/CaloTB example
Goto Forum:

Current Time: Sat Sep 14 22:47:55 Pacific Daylight Time 2019
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.1.
Copyright ©2001-2010 FUDforum Bulletin Board Software