Linear Collider Forum



Home » Software Tools » LCIO » Meeting Minutes
icon2.gif  Re: minutes of meeting 03/15/04 [message #31 is a reply to message #30] Tue, 16 March 2004 01:37 Go to previous messageGo to previous message
gaede
Messages: 233
Registered: January 2004
Location: DESY, Hamburg
Concerning Normans proposal to drop the 'get' from the simple accessors:
I like the idea of having shorter names for the methods but feel that it would be inconsistent to have a different naming convention for already released classes, e.g. MCParticle and the newer reconstruction objects. Users doing analysis comparing MC properties to reconstructed properties would probably find it odd to write
double eRatio = mcp->getEnergy() / rcp->e() ;
My proposal would be to leave the 'get' in the base interface for persistency (namespace DATA and hep.lcio.data respectively)
and add additional methods with shorter names to the EVEN/hep.lcio.event interface. Thus users can choose whatever names they prefer. A similar approach has been realized in CLHEP where the HepLorentzVector has a number of equivalent methods with different names to ease the use and readability of the code.
-Frank.
 
Read Message
Read Message icon2.gif
Read Message feedback.gif
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic:segfaulting PIDHandler in python
Goto Forum:
  


Current Time: Wed Oct 17 04:41:37 Pacific Daylight Time 2018
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.1.
Copyright ©2001-2010 FUDforum Bulletin Board Software