Linear Collider Forum

Home » Software Tools » Marlin et al » [ilcinstall] Minor problems with ilcsoft-install and related scripts. (lsb_release quirk and Java path finding issues)
[ilcinstall] Minor problems with ilcsoft-install and related scripts. [message #2266] Fri, 05 July 2013 15:44
Messages: 7
Registered: July 2013
Location: FNAL
Hi all,

I ran into two very minor issues when running ilcsoft-install on my Arch Linux laptop.

The first issue that came up was the following error message:

[aconway@tp ilcinstall]$ python2 ilcsoft-install -i ./examples/slic/release-scratch.cfg
+ Running ilcsoft-install [ v01-17-02 ]
+ Read configuration file [ /home/aconway/fermi/ilcinstall/examples/slic/release-scratch.cfg ]
Traceback (most recent call last):
  File "ilcsoft-install", line 72, in <module>
    execfile( config_file )
  File "/home/aconway/fermi/ilcinstall/examples/slic/release-scratch.cfg", line 28, in <module>
    ilcsoft = ILCSoft( ilcsoft_install_dir )
  File "/home/aconway/fermi/ilcinstall/ilcsoft/", line 70, in __init__
    self.release_number = release_string['\d', release_string).start()]
AttributeError: 'NoneType' object has no attribute 'start'

It turns out that release_string is defined on line 65 of as the output of `lsb_release -d 2>/dev/null`. On my computer, that command outputs "Description:\tArch Linux", which doesn't have any numbers. Thus the regex on line 70 returns a null value. I got around it by deleting line 70, which didn't seem to mess anything up.

The second issue was in finding my Java installation. My Java binaries are in /opt/java/bin so I couldn't add the path to ilcsoft/ because the strings in self.reqfiles[] are automatically prepended with '/usr/'. I fixed this by symlinking java, javac, jar and javadoc to /usr/bin, but a cleaner solution would have been nicer. In my case the correct paths could have been acquired simply through `which java` etc.

Alex Conway
aconway at fnal dot gov
Read Message
Previous Topic:[ilcinstall - SLIC] SLIC compilation errors [SOLVED]
Next Topic:[ilcinstall - slicPandora] "NameError: name 'SlicPandora' is not defined"
Goto Forum:

Current Time: Sun Feb 16 13:33:27 Pacific Standard Time 2020
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.1.
Copyright ©2001-2010 FUDforum Bulletin Board Software